#816 ✓fixreleased
Steve Mayer

Latest test build is highly unstable

Reported by Steve Mayer | June 18th, 2014 @ 02:54 PM

Downloaded the latest test build this morning 1.8 (4329) and it's HIGHLY unstable. When it doesn't lock up, after about 30 seconds, all of my 'read' mail now shows up in bold (as if unread), but I'm unable to view any of the messages at that point.

Most of the time it simply hangs.

I've included a sample and a spindump output. Let me know if there's anything else I can provide.

Thanks!

Comments and changes to this ticket

  • benny

    benny June 18th, 2014 @ 06:34 PM

    I was offline for a few hours, but now I have pulled the update. I'll look into it, but I don't yet know what the issue is. I might have to ask you to run it again. The following is a link to the previous test release. I assume that was stable for you: http://updates.mailmate-app.com/archives/MailMate_r4317.tbz

  • Steve Mayer

    Steve Mayer June 18th, 2014 @ 06:45 PM

    Benny,

    Yes, 4317 was working just fine for me.

    I'll be more than happy to run 4329 again to get you the info you need. Just let me know.

    Thanks!

  • benny

    benny June 18th, 2014 @ 07:51 PM

    I've fixed a hang leading to a crash, but I don't think it's the one you have reported. Anyways, please try this update: http://updates.mailmate-app.com/archives/MailMate_r4331.tbz

  • Steve Mayer

    Steve Mayer June 18th, 2014 @ 08:08 PM

    This build doesn't hang, but it doesn't load any of my mailboxes. Reverting back to 4317 works fine still.

    The only things I see related to MailMate in the console log when attempting to run 4331 are the following:

    6/18/14 12:52:48.873 MailMate[77461]: Fatal: Removing mailboxes with different parents ((null) != Mailing Lists).

    6/18/14 12:54:49.942 MailMate[81576]: Error loading /Users/smayer/Library/Contextual Menu Items/iGetterCMPlugIn.plugin/Contents/MacOS/iGetterCMPlugIn: dlopen(/Users/smayer/Library/Contextual Menu Items/iGetterCMPlugIn.plugin/Contents/MacOS/iGetterCMPlugIn, 262): Symbol not found: _method_getArgumentInfo
    Referenced from: /Users/smayer/Library/Contextual Menu Items/iGetterCMPlugIn.plugin/Contents/MacOS/iGetterCMPlugIn Expected in: /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation

    6/18/14 12:54:49.942 MailMate[81576]: Cannot find function pointer iGetterCMPluginFactory for factory 780C03AF-B5CE-11D6-A0A9-0005029E5A27 in CFBundle/CFPlugIn 0x13747e0 (bundle, not loaded)

  • benny

    benny June 19th, 2014 @ 09:54 AM

    Try this update: http://updates.mailmate-app.com/archives/MailMate_r4334.tbz

    I believe it fixes the crashes/hangs, but I'm unsure about the unread messages although if that was a problem then I would also expect r4317 to fail.

  • Steve Mayer

    Steve Mayer June 19th, 2014 @ 02:22 PM

    Thanks Benny. Initial tests with 4334 are good! No crashes, no hangs and messages are visible. Will update if anything 'undesired' surfaces :)

  • benny

    benny September 28th, 2017 @ 06:04 AM

    • State changed from “new” to “fixreleased”

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Attachments

Referenced by

Pages