#926 new
Diego Solano

Mailmate very slow and syncing forever

Reported by Diego Solano | October 10th, 2014 @ 08:43 PM

Hi, I have 2 Google Apps Account and 1 gmail account (offline). Every time I open Mail Mate is slow and syncs continuously, in fact, this is the reason I stopped using Mail Mate. What do you think is happening?

Comments and changes to this ticket

  • benny

    benny October 14th, 2014 @ 07:35 AM

    It's either a performance issue with MailMate if you have large accounts (100K+ messages) or a bug which triggers MailMate to somehow busy loop with the server.

    If you haven't already done so then try the latest beta via the Software Update preferences pane. After that you can try take individual mailboxes offline under SOURCES. This might help track down if the issue is a specific mailbox. Then update this ticket.

  • Diego Solano

    Diego Solano January 26th, 2015 @ 02:59 AM

    Hi Benny, I know it's been a long time. Nonetheless I still have the same problem even after doing what you told me,

    Thanks

    DS

  • benny

    benny January 26th, 2015 @ 10:11 AM

    Ok, I'll have to ask you to update again. This time try the latest 64 bit release of MailMate.

    If the problem persists then you can create server logs for me like this:

    • Open the Activity Viewer (⌥⌘0).
    • Wait a bit.
    • Use “Help ▸ Send Server Logs”.

    Also, how many messages do you have (estimated)?

  • Paul

    Paul May 2nd, 2015 @ 10:48 AM

    This was my problem as well, discussed in another thread.

    I think we all understand that things are slow when there are many messages to handle, slow connections, slow servers etc. These are facts of life.

    And it's why I would really like to see some very informative and meaningful (for users at all levels) activity information which tells the user exactly what is going on at all times.

  • Thomas McMahon

    Thomas McMahon September 4th, 2015 @ 03:17 PM

    My All Mail folder takes forever too. Just sent the Server Logs to see if that helps.

  • benny

    benny September 9th, 2015 @ 01:09 PM

    @Thomas: Thanks for the log files. I'm not sure why it takes forever, but it might “just” be because it takes a long time to synchronize and this happens every time something involves the “All Mail” mailbox, e.g., when archiving an email.

    In the latest experimental release of MailMate I've fixed a bug related to the handling of Gmail labels when a mailbox is in the IDLE state (the INBOX) and I've changed it such that All Mail is also kept in the IDLE state -- this should prevent it from being synchronized so often. I've also made other changes and therefore you might have other issues. Download it directly here. I am, of course, very interested in knowing whether or not this improves on the “forever” synching behavior.

  • Thomas McMahon

    Thomas McMahon September 16th, 2015 @ 01:57 PM

    I feel it's better. I don't seem to be seeing as many loading icons.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages