#898 new
Antti Honkela

Folders becoming read-only after moving a message there

Reported by Antti Honkela | September 11th, 2014 @ 12:16 PM

I relatively often run into a problem when trying to move messages to a folder where MailMate fails to complete the operation.

Folders suffering from the problem are distinguishable by the lack of folder icon next to the folder name in the list.

Drag and drop of messages fails with the folder not shown as a potential target, while move dialog appears to work fine but the message is not moved.

Taking the account offline and back online seems to reset the issue, until it appears again after moving more messages.

Steps to reproduce:
1. Move some messages to a given folder. After some time, the folder icon disappears.
2. Attempts to move another message to the same folder will fail.

Comments and changes to this ticket

  • benny

    benny September 12th, 2014 @ 03:29 PM

    Do you have more than 1 account? If yes, do you see this with all accounts?

    Do you see the same behavior using “Message ▸ Move to Mailbox…”?

    Try updating to the latest beta (see the Software Update preferences pane).

  • Antti Honkela

    Antti Honkela September 15th, 2014 @ 06:38 AM

    I have 2 accounts, and the problem only seems to affect one of them. The affected account appears to use Courier-IMAP, the unaffected one is Gmail.

    Accessing the command through the menu item behaves in exactly the same way as using the keyboard shortcut: affected folders appear in the list with just the name but no folder icon, and an attempt to move something silently fails.

    Updating to the latest beta did not cure the issue, I am still seeing the same problem.

    If this helps at all, it seems that in some cases there may be a delay between moving the messages and the folder becoming inaccessible, i.e. the folder works fine for a few minutes, but eventually becomes inaccessible for new writes.

  • benny

    benny September 15th, 2014 @ 12:31 PM

    When the mailbox is accessible is it then really synchronized with the server? That is, can you see the messages server-side or with another IMAP email client?

    You can create server logs for me as follows:

    • Open the Activity Viewer (⌥⌘0). This enables logging.
    • Trigger the problem and wait for the mailbox to become inaccessible.
    • Use “Help ▸ Send Server Logs” to send me the result.
  • Antti Honkela

    Antti Honkela September 16th, 2014 @ 08:49 AM

    I sent the logs yesterday evening.

    All changes that I can successfully make in MailMate propagate to the server and other IMAP clients. Changes made by other IMAP clients to "read-only" mailboxes do not become visible in MailMate, so it appears the connection is lost both ways there.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages