#737 accepted
Brian May

OpenGPG Signing doesn't work.

Reported by Brian May | April 29th, 2014 @ 05:45 PM

I created a signing identity with OpenPGP and can sign messages with other email clients, but with MailMate, when I try to send the email I get the following error:

USERID_HINT <neutered>  
NEED_PASSPHRASE 0<neutered>A 0<neutered>A 17 0  
GOOD_PASSPHRASE  
BEGIN_SIGNING H2

Doesn't this mean that it should be OK to sign?

Running gpg (GnuPG/MacGPG2) 2.0.22
and the latest beta for MailMate 4199

Comments and changes to this ticket

  • benny

    benny April 29th, 2014 @ 10:04 PM

    Based on the output, it seems like it's hanging. You can try enabling debug output like this (in the Terminal):

    defaults write com.freron.MailMate MmDebugSecurity -bool YES
    

    And then launch MailMate like this:

    /Applications/MailMate.app/Contents/MacOS/MailMate
    

    Part of the output is the gpg2 command used and its arguments. You can try that manually and see if that works.

    Thanks in advance.

  • benny

    benny May 1st, 2014 @ 07:21 AM

    • State changed from “new” to “accepted”

    Ah, I think this is actually a known issue which I haven't fixed yet. A workaround is available with the following setting:

    defaults write com.freron.MailMate MmOpenPGPHashFunction -string sha256
    

    This is not a permanent solution, but it might work for you for now. (Restart MailMate.)

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Referenced by

Pages