#2827 ✓closed
MGi

O365 hared mailbox with OAuth

Reported by MGi | May 25th, 2021 @ 02:58 PM

Hello,

I was using an O365 shared mailbox by configuring a separate source with 'my@email.tld\mailbox'. That works fine with username+password, but I can't get that working with OAuth.

When I switch the shared mailbox source to OAauth, I'm forwarded to the MS login page, but with the 'my@email.tld\mailbox' username, which is non-existing.

Is there any workaround for that?

Comments and changes to this ticket

  • benny

    benny May 27th, 2021 @ 03:32 PM

    I don't really know to be honest. Can you make it work in Thunderbird? (Which handles OAuth2 the same way as MailMate I believe.)

  • MGi

    MGi May 27th, 2021 @ 08:09 PM

    I'll try to test that over the weekend. I'll let you know then.

  • MGi

    MGi June 10th, 2021 @ 05:07 PM

    Sorry for the late reply.

    I just tested Thunderbird and Postbox. I can connect the user on both when I change it manually to my@email.tld only, but neither can download email or even load mailboxes :/

    It seems the only way is to use the web Outlook for now.

  • benny

    benny June 22nd, 2021 @ 06:02 PM

    • State changed from “new” to “closed”

    If this changes and there appears to somehow be something MailMate can do then we can reopen the ticket.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages