#2803 new
Klay

Markdown preview intermittently blank (just a white page)

Reported by Klay | April 10th, 2021 @ 11:59 AM

Using 5973 I sometimes get a scenario where the markdown preview pane doesn't work in widescreen. More often than not a restart fixes the issue, but sometimes I have to do this a few times to get it work.

If change to a 3 pane view, sometimes the problem persists, sometimes it clears.

Good news is that crashes are extremely rare, in fact I can't recall one for the past two releases.

Comments and changes to this ticket

  • benny

    benny April 12th, 2021 @ 12:09 PM

    You mean the message preview in the main window?

    Is it triggered by a particular type of email (large, HTML, ...)? What happens if you select a few other emails and go back to the “buggy” one?

    Do headers display in the message view?

    Does it appear to only happen in widescreen mode?

  • Klay

    Klay April 12th, 2021 @ 04:10 PM

    You mean the message preview in the main window?

    CORRECT.

    Is it triggered by a particular type of email (large, HTML, ...)?

    HTML emails. However, when triggered, it then affects all emails.

    What happens if you select a few other emails and go back to the “buggy” one?

    Sometimes it recovers, sometimes it requires a reboot.

    Do headers display in the message view?

    Yes the do.

    does it appear to only happen in widescreen mode?

    Mostly yes, I have seen it in three pane view occasionally.

  • benny

    benny April 14th, 2021 @ 07:40 AM

    By “reboot” you mean relaunch, right?

    The fact that it affects all subsequent emails is interesting. This indicates some kind of deadlock which might require something to time out before it then works again (if not relaunching). Therefore, I suspect it's related to running an external script.

    Could you try launching from a Terminal window and then see if there is any output when this happens:

    /Applications/MailMate.app/Contents/MacOS/MailMate
    

    Also, I note that you write that multiple relaunches are some times needed (in your original description). Do you think the issue might be triggered by specific emails?

    Does resizing the window make any difference (this triggers some re-layouting of the message view)?

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages