#2782 ✓cantreproduce
Des Dougan

iCloud IMAP Error

Reported by Des Dougan | March 19th, 2021 @ 04:05 PM

I started receiving pop-ups from MailMate this morning:

MailMate encountered the following error: “Server response: “C3 BAD Partition pending requests queue is full: partitionMaxPending=128 (took 2309 ms)”.”.
Mailbox: “Junk”.

I tried Retry and it went away for a bit, then came back multiple times. I closed and reopened MM and am seeing them still. I've not yet rebooted my laptop.

Version 1.13.2 (5673)

Thanks, Benny.

Des

Comments and changes to this ticket

  • Des Dougan

    Des Dougan March 19th, 2021 @ 04:06 PM

    As I was posting this, I noticed on the create ticket window:

    "Upload Quota Reached. Please notify the account owner."

  • benny

    benny March 19th, 2021 @ 08:16 PM

    • State changed from “new” to “cantreproduce”

    Rebooting won't help. This appears to be a server issue. For now, you can try taking the Junk mailbox of the account offline, e.g., for 24 hours. Then take it online to see if the issue has gone away.

    (I have no idea what the iCloud IMAP error message means and I've never seen it before. It seems to be rare since googling for it didn't reveal anything.)

  • Des Dougan

    Des Dougan March 22nd, 2021 @ 05:23 PM

    After I told it not to retry, the message has not reappeared.

    Thanks for getting back to me, Benny.

  • benny

    benny March 22nd, 2021 @ 07:00 PM

    Make sure the Junk mailbox in the account is back online. Find it under Sources in the mailbox list.

  • Mark Chapman

    Mark Chapman March 29th, 2021 @ 05:20 PM

    In case it is helpful I have started to get a similar message today:

    MailMate encountered the following error: “Server response: “D3 BAD Partition pending requests queue is full: partitionMaxPending=128 (took 3228 ms)”.”.
    Mailbox: “Junk”.

    Retry just brings it back moments later. Oddly, I got a similar error for another mailbox earlier and Retry made it go away.

    Server response: “D3 BAD Partition pending requests queue is full: partitionMaxPending=128 (took 711 ms)”.”.

    Mark

  • Jon

    Jon March 29th, 2021 @ 05:25 PM

    Got the same error as Mark today.
    In my case MailMate seemed to have been locked up and one of buttons on the dialog were clickable (grayed out).
    Even stranger after I force quit MailMate, the dialog is still on my scree.
    When I opened MailMate back up it was not responding for about 2 minutes, then it came back up...

  • benny

    benny March 29th, 2021 @ 08:04 PM

    This still seems to me to be a server issue, but I've had several reports about it recently. @Jon: Maybe MailMate isn't handling this error as gracefully as it should. Could you generate logs for me like this if possible:

    • Open the “Activity Viewer” in MailMate (Window menu). This enables logging.
    • Observe a few rounds of this error.
    • Use “Help > Send Server Logs”.

    Then I'll see if MailMate could be part of the problem.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages