#2754 new
Mike Conley

r5757: Background colour in Viewer Preview pane ignored

Reported by Mike Conley | February 8th, 2021 @ 01:20 PM

I just updated to r5757, and noticed that the Preview pane in the Viewer no longer respects the background colour setting defined in ~/Library/Application\ Support/MailMate/Resources/MmMessagesWebView/stylesheet.css.

The Editor window works as expected, however.

Comments and changes to this ticket

  • Mike Conley

    Mike Conley February 9th, 2021 @ 01:32 PM

    Or maybe it's meant to be the MmMessageTextView/display.plist file. Not sure which one is the one that's not working.

  • Mike Conley

    Mike Conley February 9th, 2021 @ 02:02 PM

    I noticed that the MmMessagesWebViewWebKitUserStyleSheetLocationPreferenceKey preference had a path in /var/folders specified, so I changed it to point to my customised stylesheet.css file (see above), then relaunched MailMate, but it made no difference in the Viewer window appearance. (MmMessagesWebViewWebKitUserStyleSheetEnabledPreferenceKey is set to 1, by the way.)

  • Anthony Craig

    Anthony Craig February 23rd, 2021 @ 01:36 PM

    I noticed that MailMate is not paying attention to any of the CSS changes made to the file ~/Library/Application\ Support/MailMate/Resources/MmMessagesWebView/stylesheet.css (MailMate is supposed to prefer that stylesheet if it exists.)

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages