#2202 reproduced
Shkodran Gerguri

Mailmate freezes when replying to emails

Reported by Shkodran Gerguri | December 12th, 2018 @ 10:28 AM

When replying to an email, MailMate will freeze for a few seconds before opening a window for composing a response. Oftentimes, it will also freeze when composing the response in the response window in between keypresses (with a spinning beachball) which is making it completely unusable for any kind of communication.

This is happening on a top-of-the-line 2017 MB Pro with the latest version of High Sierra.

Comments and changes to this ticket

  • benny

    benny December 14th, 2018 @ 10:18 AM

    • State changed from “new” to “reproduced”

    I've seen in the past that for some users inlining CSS is unusually slow. Could you try and see if this is also a problem in your case. You can do this by changing the two inlining related popups in the Composer preferences pane.

    This is not meant as a solution. It's just me trying to narrow down the main source of the issue. Especially, when typing in the Composer.

    Hmm, it appears I do have an unusual delay when replying to HTML emails which does not appear to be related to the above (but still related to some external scripts called when generating an email). When I have time I'll look into that.

  • benny

    benny December 14th, 2018 @ 10:26 AM

    I should add that you can get a refund if needed. I can then update this ticket if I believe I've fixed/improved anything related to this issue.

  • Shkodran Gerguri

    Shkodran Gerguri December 14th, 2018 @ 01:14 PM

    Confirmed that changing the inlining to a combination of "Scoped Stylesheet" and ("None" or "Stylesheet") fixes the problem. I am happy to wait for a fix, there's no such thing as a bug-free piece of software. :)

  • PerB

    PerB December 15th, 2018 @ 07:53 PM

    Similar issue here, except that the pinwheel of death never goes away, so cannot send new message, or reply to existing thread. User for many years, lost account info so created a new one, apologies.

    Attempted the fix that worked for SG, no change in behavior.
    OS X 10.8.5, issue appeared as soon as 1.12.3 installed, and cannot find link to roll-back..

  • benny

    benny December 17th, 2018 @ 03:06 PM

    @PerB: Try downloading the latest test release: Hold down ⌥ when clicking “Check Now” in the Software Update preferences pane. If
    that doesn't help then older releases can be found
    here.

    @Shkodran: I think I found another issue with replying to HTML emails which makes the issue worse than normal, but it'll take some time before
    I can look into it. Sorry about the inconvenience.

  • PerB

    PerB December 17th, 2018 @ 03:31 PM

    Thanks, updated from 5579, to 5582 by method suggested, no change in activity.
    downgraded to 5554. Can reply to both plain text and HTML threads, and create new. re-set inline and inlineCSS, no change in activity. Lost history of addresses sent to in the process but seemingly no other side effects I can see. Will standby for recommendations/tests.
    -Cheers

  • Shkodran Gerguri

    Shkodran Gerguri December 17th, 2018 @ 03:33 PM

    Thanks for the update, @benny. Happy to wait for this to get fixed, as long as this does not slip from the list.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages