Lighthouse has a new layout. Prefer the old one? Return to the old layout, and switch back any time from the link at the top of each page.

Unable to "retrieve mailbox" with IMAP4 account

#1966

New mail mate user.

When I try to refresh my IMAP4 account the source is listed as "Unavailable".

I attempted to edit the account and verify the changes by connecting with the "edit subscriptions" dialog box however this returns "Unable to retrieve mailbox\Error ""[OK]"

The logs seem to say that the connection was "successful" and the user was authenticated but not connected. Any idea why/how to resolve this?

I've done the standard things like updating to the latest release and restarting program/computer.

I don't control the server (work account), but need to be able to use this particular email account with MailMate.

From the log:

03:30:09 Handling reply
03:30:09 Running action
03:30:09 Sending request (40)
03:30:09 Handling request
03:30:09 Trying to disconnect nicely (8)...
03:30:09 C: A4 LOGOUT
03:30:09 S: * BYE Microsoft Exchange Server IMAP4 server signing off.
03:30:09 S: A4 OK LOGOUT completed.
03:30:09 Clearing connection to outlook.office365.com
03:30:12 Ready to run action (retry count: 3)
03:30:12 Clearing connection to outlook.office365.com
03:30:12 Trying to connect to outlook.office365.com on port 993 (CFNetwork) without STARTTLS (required)
03:30:12 Resolved hostname (outlook.office365.com).
03:30:12 Prepare secure connection...
03:30:12 Successful connection.
03:30:12 Initiating secure connection...
03:30:12 Returned (4)...
03:30:12 Protocol version: kTLSProtocol12
03:30:12 S: * OK The Microsoft Exchange IMAP4 service is ready. [QgBOADMAUABSADAAMwBDAEEAMAAwADgANAAuAG4AYQBtAHAAcgBkADAAMwAuAHAAcgBvAGQALgBvAHUAdABsAG8AbwBrAC4AYwBvAG0A]
03:30:12 C: A0 CAPABILITY
03:30:12 S: * CAPABILITY IMAP4 IMAP4rev1 AUTH=PLAIN AUTH=XOAUTH2 SASL-IR UIDPLUS MOVE ID UNSELECT CHILDREN IDLE NAMESPACE LITERAL+
03:30:12 S: A0 OK CAPABILITY completed.
03:30:12 Retrieving password (keychain or user request)
03:30:12 C: A1 AUTHENTICATE PLAIN ••••••••••
03:30:13 S: A1 OK AUTHENTICATE completed.
03:30:13 C: A2 CAPABILITY
03:30:13 S: * CAPABILITY IMAP4 IMAP4rev1 AUTH=PLAIN AUTH=XOAUTH2 SASL-IR UIDPLUS MOVE ID UNSELECT CLIENTACCESSRULES CLIENTNETWORKPRESENCELOCATION BACKENDAUTHENTICATE CHILDREN IDLE NAMESPACE LITERAL+
03:30:13 S: A2 OK CAPABILITY completed.
03:30:13 C: A3 ID ("name" "MailMate" "version" "r5461" "vendor" "Freron Software" "contact" "mm-imap-id@freron.com")
03:30:13 S: A3 BAD User is authenticated but not connected.
03:30:13 Warning: Detected Exchange IMAP server response state bug. Trying to work around it by interpreting it as a temporary connection issue.
03:30:13 Error code: 1003
03:30:13 Failed action (1000). Reset observed read/write timeouts: 8/8

03:30:13 Handling reply
03:30:13 Error: Failed multiple retries (4). Final error code was 1003.
03:30:13 Terminating non-running connection...

Reported by MS · March 12th, 2018 @ 03:43 AM

State: new
Milestone: none
Assigned to: benny benny

Activity

  1. benny
    benny

    It's actually telling you the problem and how it handles it:

    Warning: Detected Exchange IMAP server response state bug. Trying to work around it by interpreting it as a temporary connection issue.
    

    This is a workaround which exists because Exchange IMAP servers some times “lose” their connection to some backend. This is a server issue and there's nothing MailMate can do about it other than trying again a bit later (which is why it says “unavailable”). The BAD response is an incorrect response (since it indicates a syntax problem), but MailMate detects it such that you won't see a requester every time it happens. Exchange IMAP servers can be somewhat unreliable.

    You need to contact the IMAP server administrators if the problem persists... Oh, I see that it's an office365.com server. I hope that means it's a question of time before the issue is fixed server-side, because I really cannot do anything from my end.

    March 12th, 2018 @ 09:43 AM

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.