#1907 ✓fixreleased
vic239

Composer sender drop down name Incorrect for email address

Reported by vic239 | January 8th, 2018 @ 12:05 PM

Hello.

I have a problem setting the correct “From” address from the composer drop down list of aliases/identities since receiving an email with a partial “To” name.

To explain, I have four email addresses in the list of addresses in the IMAP Account Settings.

user1@domain.name, FirstName2 Surname <user2@domain.name>, FirstName3 Surname <user3@domain.name>, OtherName <user4@domain.name>

I received an email with just “Surname user3@domain.name” in the “To” field, which I appear to have replied to, and since then the drop down only offers “Surname user3@domain.name” in the list. The other aliases are unchanged. Also since receiving this email all references to “user3@domain.name” in all other folders are now named “Surname” even although the raw header is correct.

I have removed the offending email from my Sent folder, but the problem remains. I have also rebuilt the MailMate database with no change.

I this expected behaviour or is there some hidden preference at play here?

I have the following set:

defaults write com.freron.MailMate MmEnableKeywordsCheckInIDLE -bool YES  
defaults write com.freron.MailMate MmMessagesOutlineMoveStrategy -string "next"  
defaults write com.freron.MailMate MmMessageWindowActionAfterMove -string "closeWindow"  
defaults write com.freron.MailMate MmIgnoreDeliveryAddresses -bool NO  
defaults write com.freron.MailMate MmForwardingDeriveIdentityFromRecipient -bool NO  
defaults write com.freron.MailMate MmDebugDerivedIdentity -bool NO  
defaults write com.freron.MailMate MmNeverDeriveSenderBasedOnRecipient -bool YES

Any help appreciated.

Thanks … Andy.

Comments and changes to this ticket

  • benny

    benny January 9th, 2018 @ 10:37 AM

    Hmm, seems strange that receiving an email would affect the “From” popup (unless I'm forgetting something). Could you use “Help ▸ Send Feedback” to send me your .plist files:

    ~/Library/Application Support/MailMate/Sources.plist
    ~/Library/Application Support/MailMate/Submission.plist
    ~/Library/Application Support/MailMate/Identities.plist
    

    I can then try to see if I can reproduce the issue without any sent messages involved.

    Thanks in advance.

  • benny

    benny January 9th, 2018 @ 01:21 PM

    • State changed from “new” to “fixcommitted”
  • benny

    benny March 13th, 2018 @ 12:54 PM

    • State changed from “fixcommitted” to “fixreleased”

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages