#1514 ✓cantreproduce
Andreas Jung

HTML display broken in 1.9.5

Reported by Andreas Jung | August 30th, 2016 @ 04:40 AM

Since my upgrade to r5255 displaying HTML mails is partly broken.

Here is a sample how the mail is rendered by MM and within Google Mail (including source EML file).

http://public.zopyx.com/mailmate/

The original HTML markup is also much different from the one shown by MailMate with its myriades of

....

inside the HTML.

Comments and changes to this ticket

  • Andreas Jung

    Andreas Jung August 30th, 2016 @ 04:41 AM

    HTML filtering of the issue seems to have eaten the HTML tags I posted in my original posting.

    MM displays the HTML source with tons of DIV tags with dir=auto attribute.

  • benny

    benny August 30th, 2016 @ 08:27 AM

    • State changed from “new” to “cantreproduce”

    The HTML source is the result of MailMate generating HTML from a plain text message part. MailMate isn't trying to display the HTML at all (based on the screenshots).

    Maybe you have selected “Prefer Plain Text” in the Viewer preferences pane? (The default for this setting has not changed, but if there's a bug then it's somehow related to MailMate choosing to display the plain text alternative instead of the HTML without being asked to do so.)

    MailMate also remembers (for individual emails) if you have explicitly selected a different message part using “View ▸ Message Body Parts” (possibly via a shortcut).

  • Andreas Jung

    Andreas Jung August 30th, 2016 @ 08:33 AM

    Yes, you are right. My mistake.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages