Lighthouse has a new layout. Prefer the old one? Return to the old layout, and switch back any time from the link at the top of each page.

v2169: "expected end of data instead of" error with some IMAP accounts

#145

After updating to 2169 the IMAP sync of two of my accounts fail with the error "A3 BAD expected end of data instead of..." (screenshot attached). These accounts are with GMX and 1&1. Other accounts with Gmail and Rackspace work fine.

Is this a known problem? If not, can I send additional data to help in debugging?

Reported by mariow · June 2nd, 2011 @ 12:34 PM

State: fixreleased
Milestone: none
Assigned to: benny benny

Activity

  1. benny
    benny
    • State changed from new to fixcommitted

    Someone else just reported the issue by email (with gmx.net). Turns out
    to be a bug that it worked at all in version 1.1.2. I think the problem
    is that the authentication method used is buggy at gmx.net (and some
    other servers). They advertise an authorization method which they don't
    really support.

    I've now made a workaround such that if it fails with 'BAD' then it
    retries with a different authentication method.

    I haven't bumped the revision number yet, so to get the new version you
    should hold down ⇧ while selecting “Check Now...”

    If it works for you as well I'll bump the revision number and make it a
    proper update.

    [state:fixcommitted]

    June 2nd, 2011 @ 12:40 PM

  2. mariow
    mariow

    Wow, that's a quick fix!
    Works fine after updating, thanks!

    June 2nd, 2011 @ 12:47 PM

  3. benny
    benny
    • State changed from fixcommitted to fixreleased

    [state:fixreleased]

    June 2nd, 2011 @ 01:21 PM

  4. benny

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.