#1436 ✓resolved
Jason Quigley

Forward not using address pattern...

Reported by Jason Quigley | March 8th, 2016 @ 11:45 AM

Hi Benny!

When I forward an email to a particular address, it always uses the last from address. This is a pain when trying to forward to a spam/ham address as I have to customise the from address every single time :-(

Shouldn't this function the same way as replying with an address pattern regex?

Thanks,
Jason.

Comments and changes to this ticket

  • benny

    benny March 8th, 2016 @ 12:49 PM

    Could you try the latest test release to see if this is still an issue: Hold down ⌥ when clicking “Check Now” in the Software Update preferences pane.

  • benny

    benny March 8th, 2016 @ 01:25 PM

    It should be disabled or not configured:

    defaults read com.freron.MailMate MmForwardingDeriveIdentityFromRecipient
    

    You can debug what MailMate by running from the Terminal like this:

    defaults write com.freron.MailMate MmDebugDerivedIdentity -bool YES
    /Applications/MailMate.app/Contents/MacOS/MailMate
    

    You can send the output via email if you spot something suspicious.

    Are the previously forwarded emails in “Sent Messages”?

    Lighthouse: And this happened because MailMate used the wrong From address when you reply as well?

  • benny

    benny March 9th, 2016 @ 12:31 PM

    • State changed from “new” to “resolved”

    I'm glad you found a solution.

    The ticket issue sounds like a Lighthouse problem if the from address was correct.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages