#1253 ✓resolved
Joonho Kim

Authentication error

Reported by Joonho Kim | September 2nd, 2015 @ 08:29 AM

08:19:16 Running action
08:19:16 Sending request (384)
08:19:16 Handling request
08:19:16 Trying to disconnect nicely (8)...
08:19:16 C: A3 LOGOUT
08:19:16 Error: Error sending data.
08:19:16 Clearing connection to mail.kias.re.kr
08:19:16 Ready to run action
08:19:16 Clearing connection to mail.kias.re.kr
08:19:16 Trying to connect to mail.kias.re.kr on port 993
08:19:16 Successful connection on socket 40.
08:19:16 Initiating secure connection...
08:19:16 Setup of secure connection complete (TLSv1).
08:19:16 Cipher: DHE-RSA-AES256-SHA SSLv3 Kx=DH Au=RSA Enc=AES(256) Mac=SHA1
08:19:16 S: * OK IMAP4 TIMS(7.46.2014110611) server ready protocol-version:1.0
08:19:16 C: A0 CAPABILITY
08:19:16 S: * CAPABILITY IMAP4 IMAP4rev1 SPECIAL-USE STARTTLS NAMESPACE QUOTA SORT AUTH=PLAIN AUTH=CRAM-MD5
08:19:16 S: A0 OK CAPABILITY completed
08:19:16 Retrieving password (keychain or user request)
08:19:16 C: A1 AUTHENTICATE CRAM-MD5
08:19:16 S: + PDIzNDMxLjE0NDExODE5NTU2MjA2MTNAbWFpbDE+
08:19:16 C: ••••••••••
08:19:16 S: A1 NO invalid user or password
08:19:16 Error: Server response: “A1 NO invalid user or password”. Command attempted: “••••••••••”.
08:19:16 Retrieving password (keychain or user request)
08:19:16 C: A2 AUTHENTICATE PLAIN
08:19:16 Error: TCP socket was unexpectedly closed.
08:19:16 S:
08:19:16 Error code: 2
08:19:16 Failed action (1000). Reset observed read/write timeouts: 8/8

Comments and changes to this ticket

  • benny

    benny September 2nd, 2015 @ 09:09 AM

    This looks like a server bug. The first attempt (with CRAM-MD5) fails possibly because of a wrong username or password. Then MailMate retries with the other authentication method (PLAIN), but this appears to trigger the server to close the connection. The server does not support any other authentication methods.

    Can you connect with other email clients?

  • benny

    benny September 28th, 2015 @ 07:39 AM

    There is actually a hidden preference to force the use of the plain login method. Maybe that'll work. Enable it in a Terminal window like this:

    defaults write com.freron.MailMate MmIMAPForcePlainLogin -bool YES
    

    Then relaunch MailMate.

    If it fails then I'd like to the see a log like the one you provided initially.

  • benny

    benny September 28th, 2015 @ 10:45 AM

    • State changed from “new” to “resolved”

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages