#1219 ✓fixreleased
Justin Levens

Connecting to Zimbra over SSL

Reported by Justin Levens | July 27th, 2015 @ 05:09 PM

I am attempting to connect to our department's Zimbra server, however, I am receiving an '(unavailable)' message next to the mailbox. Mac Mail is able to retrieve messages. The logs from the Activity Viewer can be seen here: http://cl.ly/text/440w3L3n2t46/20150727MailMateLogs.txt

I tried using a similar configuration as Mac Mail which is using port 143 which you can see in the logs, then I tried using port 443 which is what my admin said to use. It was working fine on Friday, but the Zimbra server was updated over the weekend and is now running Zimbra 8.6.0_GA_1178 (build 20150618170638).

Thanks.

Comments and changes to this ticket

  • benny

    benny July 29th, 2015 @ 11:12 AM

    If 143 works with Apple Mail then it should also work in MailMate. The problem seems to be the SSL handshake. Do you have SSL enabled in Apple Mail?

    You should not use port 443 since this an https port and not for IMAP, but you can try to see if port 993 works.

    You can try temporarily disabling SSL on port 143 in MailMate to see if this is the only problem.

  • Justin Levens

    Justin Levens August 6th, 2015 @ 03:04 PM

    Here is what my settings are like for Apple Mail: http://cl.ly/image/2V1t3h1j1m3I

    I did come across this post: https://freron.lighthouseapp.com/projects/58672/tickets/1002-force-...

    When you say disabling SSL, do you mean just don't select the 'Require SSL' box? When I do that I get 'Error: Cannot log in since LOGINDISABLED (no plain text login allowed) is reported by the server.'

    I have also tried port 993 but unfortunately it didn't work either.

  • benny

    benny August 6th, 2015 @ 04:14 PM

    • State changed from “new” to “accepted”

    Ah, thanks for finding that link. Unfortunately that issue is still the same. I haven't changed MailMate to use the Apple framework.

    There is little I can do other than promise to contact you when/if this changes, e.g., by updating this ticket.

  • Justin Levens

    Justin Levens August 6th, 2015 @ 04:54 PM

    Our server does support TLS 1, 1.1, 1.2 - does that make a difference?

  • benny

    benny August 6th, 2015 @ 05:02 PM

    Yes, then it's not the same issue. Could you provide me with the server address if it's accessible from the outside? I don't need to login I just need to be able to try connecting to the server. You can send it via “Help ▸ Send Feedback” (if you have a working SMTP server).

  • Justin Levens

    Justin Levens August 6th, 2015 @ 05:06 PM

    Okay. I sent it using Send Feedback.

  • Justin Levens

    Justin Levens August 13th, 2015 @ 06:01 PM

    @benny, just following up on this - did you receive my server address? I did see there was a new release and I have downloaded and installed it. I reviewed the release notes and it doesn't look like there was a fix for my specific problem, but it looks like things have been put in place to debug issues. Below are the logs from the activity viewer.

    17:53:49 Running action
    17:53:49 Sending request (7)
    17:53:49 Handling request
    17:53:49 Clearing connection to xxxx.xxx.xxx.xxx
    17:53:49 Ready to run action
    17:53:49 Clearing connection to xxxx.xxx.xxx.xxx
    17:53:49 Trying to connect to xxxx.xxx.xxx.xxx on port 143
    17:54:05 Error: Time limit (16s) reached while trying to write data (xxxx.xxx.xxx.xxx)
    17:54:05 Error: Failed while trying to connect to “xxxx.xxx.xxx.xxx” on socket 49.
    17:54:05 Clearing connection to xxxx.xxx.xxx.xxx
    17:54:05 Trying to connect to xxxx.xxx.xxx.xxx on port 993
    17:54:05 Successful connection on socket 49.
    17:54:05 Initiating secure connection...
    17:54:05 Error: Failed SSL handshake (-1/1).
        “error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure”
    17:54:05 Error code: 9
    17:54:05 Failed action (1000). Reset observed read/write timeouts: 8/8
    
    17:54:05 Handling reply
    17:54:05 Running action
    17:54:05 Sending request (7)
    17:54:05 Handling request
    17:54:05 Clearing connection to xxxx.xxx.xxx.xxx
    17:54:06 Ready to run action
    17:54:06 Clearing connection to xxxx.xxx.xxx.xxx
    17:54:06 Trying to connect to xxxx.xxx.xxx.xxx on port 143
    17:54:22 Error: Time limit (16s) reached while trying to write data (xxxx.xxx.xxx.xxx)
    17:54:22 Error: Failed while trying to connect to “xxxx.xxx.xxx.xxx” on socket 49.
    17:54:22 Clearing connection to xxxx.xxx.xxx.xxx
    17:54:22 Trying to connect to xxxx.xxx.xxx.xxx on port 993
    17:54:22 Successful connection on socket 49.
    17:54:22 Initiating secure connection...
    17:54:22 Error: Failed SSL handshake (-1/1).
        “error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure”
    17:54:22 Error code: 9
    17:54:22 Failed action (1000). Reset observed read/write timeouts: 8/8
    
    17:54:22 Handling reply
    17:54:22 Running action
    17:54:22 Sending request (8)
    17:54:22 Handling request
    17:54:22 Clearing connection to xxxx.xxx.xxx.xxx
    17:54:24 Ready to run action
    17:54:24 Clearing connection to xxxx.xxx.xxx.xxx
    17:54:24 Trying to connect to xxxx.xxx.xxx.xxx on port 143
    17:54:40 Error: Time limit (16s) reached while trying to write data (xxxx.xxx.xxx.xxx)
    17:54:40 Error: Failed while trying to connect to “xxxx.xxx.xxx.xxx” on socket 49.
    17:54:40 Clearing connection to xxxx.xxx.xxx.xxx
    17:54:40 Trying to connect to xxxx.xxx.xxx.xxx on port 993
    17:54:40 Successful connection on socket 49.
    17:54:40 Initiating secure connection...
    17:54:40 Error: Failed SSL handshake (-1/1).
        “error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure”
    17:54:40 Error code: 9
    17:54:40 Failed action (1000). Reset observed read/write timeouts: 8/8
    
    17:54:40 Handling reply
    17:54:40 Running action
    17:54:40 Sending request (8)
    17:54:40 Handling request
    17:54:40 Clearing connection to xxxx.xxx.xxx.xxx
    17:54:43 Ready to run action
    17:54:43 Clearing connection to xxxx.xxx.xxx.xxx
    17:54:43 Trying to connect to xxxx.xxx.xxx.xxx on port 143
    17:54:59 Error: Time limit (16s) reached while trying to write data (xxxx.xxx.xxx.xxx)
    17:54:59 Error: Failed while trying to connect to “xxxx.xxx.xxx.xxx” on socket 49.
    17:54:59 Clearing connection to xxxx.xxx.xxx.xxx
    17:54:59 Trying to connect to xxxx.xxx.xxx.xxx on port 993
    17:54:59 Successful connection on socket 49.
    17:54:59 Initiating secure connection...
    17:54:59 Error: Failed SSL handshake (-1/1).
        “error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure”
    17:54:59 Error code: 9
    17:54:59 Failed action (1000). Reset observed read/write timeouts: 8/8
    
    17:54:59 Handling reply
    17:54:59 Error: Failed multiple retries (4). Final error code was 9.
    
  • benny

    benny August 17th, 2015 @ 12:24 PM

    Sorry about the late response. I get the same error if I try connecting to the server manually:

    > openssl s_client -connect mail.xxx.edu:993
    CONNECTED(00000003)
    20296:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:/SourceCache/OpenSSL098/OpenSSL098-52.40.1/src/ssl/s23_clnt.c:618:
    

    I've tried various command line arguments for openssl, but with no luck. Since I'm using openssl within MailMate then it's unlikely I can make it work :-(

    The best I can do is to notify you when/if I replace openssl (if that's part of the problem).

  • Justin Levens

    Justin Levens November 23rd, 2015 @ 04:59 PM

    Hey Benny, I'm still bummed that I'm not able to use MailMate for this account. I continue to keep the app on my Mac and update hoping you've replaced openssl but, alas, this is not the case. Do you have recommendations for what I can do on the server level to allow MailMate to work with this account? Thanks in advance for your assistance.

  • benny

    benny August 11th, 2016 @ 06:08 PM

    • State changed from “accepted” to “fixcommitted”

    Resolved with beta release.

  • benny

    benny September 15th, 2016 @ 03:57 PM

    • State changed from “fixcommitted” to “fixreleased”

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages