Lighthouse has a new layout. Prefer the old one? Return to the old layout, and switch back any time from the link at the top of each page.

Anonymous IMAP login?

#1017

Does MailMate support AUTH=ANONYMOUS? I am trying to access an IMAP server that supports anonymous access, but I haven't been able to make it work so far. For example, I tried specifying username="ANONYMOUS" and password="ANONYMOUS" and MailMate told me this:

Error: "Cannot log in since LOGINDISABLED (no plain text login allowed) is reported by the server."

Reading around online, I see a couple ways that anonymous access can be done. For example, Section 3.2, "IMAP User Name and Authentication Mechanism" in RFC 5092. It also seems as if some servers support an old-fashioned hack, where the client sends "LOGIN ANONYMOUS ANONYMOUS;AUTH=ANONYMOUS" -- see Section 3, "IMAP User Name and Authentication Mechanism" of RFC 2192.

Does MailMate support an anonymous login mechanism?

Reported by Dave Eckhardt · January 26th, 2015 @ 08:56 AM

State: new
Milestone: none
Assigned to: benny benny

Activity

  1. benny
    benny

    It is not supported by MailMate and appears to be described in RFC 4505. Since it's anonymous then you could perhaps provide the server details and I could look into how hard it would be to add.

    January 26th, 2015 @ 10:09 AM

  2. Dave Eckhardt
    Dave Eckhardt

    Details for one example can be found here:

    OpenAFS-devel Info Page

    January 26th, 2015 @ 11:51 AM

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.