#414 new
Garry Hill

Crashing opening links

Reported by Garry Hill | July 25th, 2013 @ 07:14 AM

MailMate (build 3549) crashes everytime I click on a link.

This includes:

  • Clicking inks in emails
  • Opening attachments
  • Selecting Help -> Report an Issue
  • Clicking on a link in the "About" dialogue...

It's driving me mad.

This is true on both of my computers, one is on 10.7.5, the other 10.8.x

It's a real showstopper -- clicking on links in emails is one of those things you do a lot

I've attached a crashlog but I have crash reporting turned on so I'm guessing you've seen this already.

Would be loving this app if it weren't for the constant crashes...

Thanks,

Garry

Comments and changes to this ticket

  • benny

    benny July 25th, 2013 @ 08:05 AM

    This is new to me and it's not a general problem. I have your crash reports and they are all related to calling openURL: on the NSWorkSpace class. Since it happens no matter where MailMate calls this function makes it likely that it is actually not a MailMate bug.

    It is most likely that something installed on your machines is triggering these crashes. Looking at the crash reports I see references to various patches related to “DefaultFolderX”. Do you have this application installed on both machines?

    It also seems that DefaultFolderX is not up-to-date on your machine and there has been problems with old versions in the past (cannot remember the details, but I think it was related to save panels). Try updating or uninstalling DefaultFolderX.

  • Erik M-H

    Erik M-H July 27th, 2013 @ 03:14 PM

    FWIW, I've been running Default Folder for ten or fifteen years longer than I've been using MailMate (though always the current version), and I've never noticed any incompatibilities. And I have no problems with clicking on links. If you are running the current version of DF, you'll probably need to do some further sleuthing. Do you have problems with clicking on links in Mail or in other applications?

  • magnetised

    magnetised July 29th, 2013 @ 06:53 AM

    Maybe I wasn't clear enough in my reply but after updating Default Folder the problem went away. Links open with no problem at all. No idea how DF got so out of date but that was the problem. Back to a crash free lifestyle.

    FYI nothing else was crashing before the DF update (at least I hadn't noticed any consistent 'crash on click' behaviour).

    Many thanks,

    g

  • benny

    benny July 29th, 2013 @ 07:24 AM

    • State changed from “new” to “resolved”

    Thanks for the update.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Attachments

Pages