#2993 ✓fixcommitted
Jeff

Standard Inboxes stopped working

Reported by Jeff | January 26th, 2022 @ 10:17 PM

Currently using MailMate Version 1.14 (5864) after upgrading from 5856 (after upgrading from a build I don't remember). I am using MacOS Big Sur Version 11.6. And I am a MailMate patron.

My issue: The Standard Mailbox type of "Inbox" stopped working several weeks ago.

I have had to use Smart Mailboxes since then to re-create my own version of working Inboxes on the left nav. Each Smart Mailbox points to the "INBOX" in each specific Gmail Source of the various Gmail addresses I have attached to MailMate. (Connected to Google Workspace)

I have tried removing and re-adding accounts to MailMate and a variety of other unsuccessful tactics. It seems like something related to the Standard Mailbox type of "Inbox" is just broken.

By the way, I noticed that it broke when after I duplicated a Smart Mailbox which was nested underneath the Standard Inboxes.

It would be great if I could get this fixed.

Comments and changes to this ticket

  • Jeff

    Jeff January 26th, 2022 @ 10:22 PM

    To be more clear: Whenever I click on any MailMate standard "Inbox" it shows no items whatsoever. Even though there are many many items in each inbox. So I set up smart mailboxes pointed at each Source inbox (which accurately show the mail).

  • benny

    benny January 28th, 2022 @ 11:27 AM

    Could you check to see if you might have added conditions to the universal Inbox?

  • Jeff

    Jeff January 28th, 2022 @ 12:46 PM

    Benny - thank you for asking. Unbelievable to me, it is true that there was some "Johnny Appleseed" condition added to the universal "Inbox"! Once I removed that condition, all the standard Inboxes started working perfectly again. Thanks so much for helping - it was such a simple fix and I'm shocked I didn't catch it on my own. Thanks again! (And I LOVE MailMate, by the way.)

  • Lars

    Lars February 16th, 2022 @ 09:50 AM

    I can confirm the same condition appeared after upgrading to 5869 recently, both in "Inbox" and "All Messages". I am certain I did not set it up for either of them.

  • benny

    benny April 20th, 2022 @ 01:03 PM

    • State changed from “new” to “fixcommitted”

    Just to clear things up, I think this was possibly caused by a bug where creating a new smart mailbox would create it but then open the currently selected mailbox instead of the new mailbox, making it likely that the user would end up adding a condition to the wrong mailbox.

    Hold down ⌥ when clicking “Check Now” in the Software Update preferences pane to get the latest test release.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages