#1089 new
phil

Desactivate persistant default value in custom search

Reported by phil | March 29th, 2015 @ 11:53 AM

Command>Mailmate>Search> shows a bold header 'Message contains "consectetur"'

Details shows a value in the search field namely 'consectetur' I can't get rid of the value. Never made such search.

The consequence is that i can't use the search field in the toolbar. It is present but unusable because the value "consectetur" has the precedence. Of course if i delete "consectetur" in the field of custom search then i can make my own search. But that's not how i proceeded before.

I try >Edit>Find>Use as Default Search with a blank field but "consectetur" appears again in the custom search field.

I'm using version 1.9 (5078).
Is there a sort of MmDefaultDefaultCustomSearchValue i can reinitialize?

Thank you for your help

Comments and changes to this ticket

  • benny

    benny March 29th, 2015 @ 07:18 PM

    I believe no such default value exists, but your observations doesn't really support that. The default conditions can be read like this:

    defaults read com.freron.MailMate MmDefaultMailboxSearchFilter
    

    But it sounds like you have the problem in the toolbar search field? Is that correct? If you relaunch MailMate do you then have a value in the toolbar search field by default? Maybe send me a screenshot via “Help ▸ Send Feedback”.

  • phil

    phil March 29th, 2015 @ 08:07 PM

    thank for your answer
    Step one: i try to search on the toolbar for 'Lighthouse' . Your message is the first line and should be one of the two lines i should see
    but nothing has changed - all the mails i received stay present.

    Step two: Command>Mailmate>Search'. 'lighthouse' is always in the toolbar's search field. On the line with the buttons Details-Save-- i have in bold 'Message contains "consectetur"' and no mail appear

    Step three: i click on Details. Under Title Custom Search is 'Common Headers or Body' 'contains' 'comsectetur', the toolbar's search field is now blank and there is no found item

    Step four: i replace 'consectetur' with lighthouse and got two mails (that's correct)

    So, from where come 'consectetur' that prevents the search at the toolbar level. i want to get rid of this 'consectetur' ( so the question regarding an adhoc MmDefault... field

  • benny

    benny March 29th, 2015 @ 08:12 PM

    • State changed from “new” to “reproduced”

    Ah, I can reproduce that. I had forgotten the menu item and its behavior is kind of undefined (that's a bug).

    You are supposed to use “Edit ▸ Find ▸ Search All Messages” with the shortcut ⌥⌘F.

    With respect to step 1, the search is not performed before you hit return.

    Does this explain what you see?

  • phil

    phil March 29th, 2015 @ 08:18 PM

    correct. I have to do enter to get the result

    thank you for your prompt answer

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages