#371 accepted
Alex McMillen

Issues with Zimbra

Reported by Alex McMillen | March 31st, 2013 @ 01:20 PM

Errors such as this occur when taking common actions such as sending or editing emails, when utilizing a Zimbra IMAP (SSL) server. It occurs around 99% of the time. Doesn't occur on any other email client (Thunderbird, Postbox, etc.) which leads me to believe it's a MailMate specific bug.

MailMate encountered the following error: “Server response: “H9 NO UID STORE failed”. Command attempted: “H9 UID STORE 6924 -FLAGS.SILENT (\Draft)”.”.
Mailbox: “Drafts”.

Can't even get the error message generated for "Sent" as MailMate now considers that individual folder to be in an "Offline" state and now doesn't even attempt to save any Sent messages server-side. The error message was similar to the one above though.

Comments and changes to this ticket

  • benny

    benny April 2nd, 2013 @ 08:22 PM

    • State changed from “new” to “reproduced”

    This is a known problem. The Zimbra IMAP server is the only server I know that rejects changes to the \Draft flag and unfortunately MailMate triggers this limitation and many/most other clients do not. I've noted that I should look into a workaround since it is unlikely that the server is going to change behavior (even though this is not standard IMAP server behavior).

    I believe you can solve the problem for now by setting the \Draft flag for the message (create a tag in the Tags preferences pane to do this). If you manage to get the mailboxes online then maybe you can keep the Drafts folder offline to circumvent the problem for now (the idea is that the message is then not uploaded until after it has been moved to Sent Messages without the \Draft flag).

  • benny

    benny October 10th, 2013 @ 09:54 AM

    • State changed from “reproduced” to “fixreleased”

    I believe this (old) issue has been resolved (worked around) in the latest releases of MailMate. Let me know if it is still an issue.

  • benny

    benny November 24th, 2013 @ 12:05 PM

    First, you can fix it by moving the message to a different account and then back again (forcing MailMate to upload the message instead of trying to change its \Draft flag).

    Second, does this happen every time you send a message or does it appear to depend on a certain order of events?

  • benny

    benny January 6th, 2014 @ 09:26 AM

    • State changed from “fixreleased” to “accepted”

    @Max: I believe you can also take the Drafts mailbox offline (in the account under SOURCES). This should mean that MailMate doesn't try to put it on the server until after it has been sent (without the \Draft flag). Although I might be wrong since I'm not sure why this problem is triggered even with Drafts online. I've reopened this ticket.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages