#3153 new
Eelco Chaudron

Deleting emails do not reflect in Gmail

Reported by Eelco Chaudron | November 16th, 2022 @ 07:30 AM

In the web GUI I do the following:

  • Select an email in my inbox
  • Hit the trash icon

This will move my message from the Inbox to the Trash folder in Gmail. It has also moved from INBOX to my Trash folder in MailMate

Now on MailMate I do the following:

  • Select an email in my INBOX
  • Hit the trash icon

Now my message is removed from the MailMate INBOX and is moved to my [GMAIL] -> Trash folder in MailMate.

However, on the web GUI (and iPhone), it’s still in my INBOX and has NOT moved to my Trash folder.

So now my question remains, how should I’ve configured this? Note that this used to work before I upgraded (unfortunately I can’t remember from which test version I upgraded to Version 1.14 (5927) before it broke down).

What I’ve configured is that in the [Gmail] -> Trash folder I hit the right mouse, and select “Deleted Messages” as Mailbox type. Should I configure more??

Cheers,

Eelco

Comments and changes to this ticket

  • benny

    benny November 16th, 2022 @ 09:08 AM

    First check that all of your mailboxes are online within the account. This means no greyed out mailboxes when you expand the account under Sources in the mailbox list. Your description matches what would happen if the mailbox assigned for deleted messages is offline. In this case, MailMate cannot complete the move, that is, it's pending in MailMate.

    A mailbox shouldn't go offline unless there has been a persistent error which MailMate should have told about. Therefore it's possible that such an error will re-appear when/if you can take the mailbox online (if I'm right about the above). This might be a different issue we'll need to resolve.

    If the problem is something else then we'll debug by creating some activity logs.

  • Eelco Chaudron

    Eelco Chaudron November 16th, 2022 @ 09:29 AM

    Hi Benny,

    The mailbox is not offline, I tried taking it offline, and then back online, but no luck.

    The thing is that if I delete a message on the web GUI, it will reflect in my trash folder. The activity viewer also does not show any activity if I delete something locally.

    Please let me know what debug logs you need.

    //Eelco

  • Eelco Chaudron

    Eelco Chaudron November 17th, 2022 @ 11:45 AM

    Hi Benny,

    Any update on how to troubleshoot this? Asking as this makes using MM almost impossible. Even if I try to move some messages from my inbox to another mailbox it's only happening in MM, not in the Gmail GUI.

    In the meantime is there a way to downgrade to a previous test build safely? If so, where can I find the binaries?

  • benny

    benny November 17th, 2022 @ 03:50 PM

    Based on your reply, I think you missed what I wrote. It's partly due to a mix of terms. Some times a mailbox is used to describe an account/source, but this is not what I meant. I wrote: “This means no greyed out mailboxes when you expand the account under Sources in the mailbox list.”

    So, to make sure this is not the issue:

    • Find the “Sources” section of the mailbox list in MailMate.
    • If not already expanded then expand it.
    • Find the problematic account.
    • Make sure it's fully expanded, e.g., by holding down the option key when clicking the triangle.
    • Make sure no mailboxes within the account are offline in any way (they would then be greyed out).
    • Make sure no mailboxes have persistent spinners (which could be a sign that something is busy-looping).

    If anything is offline within the account: Use “Mailbox > Take Online” to see if it can be synchronized.

    If the above is all good and well:

    • Open the Activity Viewer (to enable logging).
    • Relaunch MailMate (to be sure to trigger a resync of the account).
    • Delete a message (which would trigger the bug).
    • Use “Help > Send Server Logs”.

    Then I'll review the result. Thanks for your patience.

  • Eelco Chaudron

    Eelco Chaudron November 17th, 2022 @ 06:58 PM

    There are no mailboxes offline, so that is not the problem. I've opened MM, wait for it to turn idle in the activity viewer, restarted MM, and first deleted an email, then moved on to the Bugzilla mailbox.

    The logs are sent your way from my work account with reference, My system: MailMate/5927/E487C22E-FB75-5088-9E68-0FD5DBAE9F9C 12.6.1/x86_64/iMac17,1/8

  • benny

    benny November 18th, 2022 @ 07:41 AM

    Thanks for the logs. Your INBOX is fully synchronized, but otherwise it appears to be busy synchronizing your (many) mailboxes. Does it every finish (spinner stops for the account)?

    To simplify the issue, you could try taking all of the mailboxes within the account offline except the INBOX and the destination mailbox for your deletes. (You can shift-select mailboxes before using “Mailbox > Take Offline”.)

    Then repeat the creation of logs. This should result in at most 2 active connections and maybe we can then see why MailMate does not think it can perform the move on the server.

  • Eelco Chaudron

    Eelco Chaudron November 18th, 2022 @ 11:14 AM

    It takes a long time before all my mailboxes get sync, no idea why though. But this problem happened even when if all is synced up...

    I sent you the logs with all mboxes disabled, except the once in [Gmail] and the INBOX.

    However I disabled all mailboxes and restarted MM, now I deleted the message with subject “XXX” and it got deleted.

    I’ve tried deleting some more messages and it worked fine.

    Now I’ve taken all mailboxes back online and waited for my account under Source to be stable, no more spinning radar, just showing the number of unread messages.

    Then I deleted another email, “XXX”, and it also got deleted :(

    So no idea what has happened here, but maybe taking all mailboxes offline and online solved the problem? I’ll continue to work with MM as usual and report back…

    //Eelco

  • Eelco Chaudron

    Eelco Chaudron November 18th, 2022 @ 11:15 AM

    PS: I send all the logs and the exact mail subjects in the direct email.

  • Eelco Chaudron

    Eelco Chaudron November 18th, 2022 @ 11:18 AM

    Actually right after updating this ticker, I got it to fail again. Send you a new log...

  • Eelco Chaudron

    Eelco Chaudron November 18th, 2022 @ 11:23 AM

    Would it make sense/is it possible to revert to an earlier version to see if it works?

  • benny

    benny November 18th, 2022 @ 11:48 AM

    With regard to “revert to an dearlier version”: No, this is not the problem.

    In your last logs I noticed the Gmail account is in a throttled state. I think this is the problem. The throttled state is likely related to the very large number of mailboxes and/or messages in the account.

    I suggest you take most of your mailboxes in the account to the “Manually” synchronization schedule (in the Mailbox menu). This won't be a problem if you mainly use MailMate to move messages. Mailboxes are always synchronized when selected/viewed. After doing this you should give the account a few hours before trying a deletion again. Google needs to detect a decrease in network activity to “release” the account from the throttled state.

  • Eelco Chaudron

    Eelco Chaudron November 18th, 2022 @ 01:52 PM

    Ok if reverting is not a problem, I only had this issue appear about two weeks ago, nothing changed, and I only added a mailbox or two.

    Even when the mailbox is not in a throttled state, it showed me the problem. However, I will try to disable most of my mailboxes with the exception of the ones I moved email to with a filter in Gmail.

    To be continued...

  • Eelco Chaudron

    Eelco Chaudron November 25th, 2022 @ 12:48 PM

    Ok, so it looks like that now most of my mailboxes are set to "manual" I no longer have the issue. I guess I was just on the edge, and when adding some more folders this issue started happening.

    I however do sometimes see that my manual folders get marked as unavailable, and it goes away if a select the folders.

    Two more questions:

    • is it possible to automatically set the newly created folder to manual?
    • is there a way to sync all my manual folders, before I step on the plane with my laptop which I have not used for a couple of weeks? I think I can expand all my folder views, and then select sync, but would be nice if I do not have to manually expand and select.
  • benny

    benny November 25th, 2022 @ 02:04 PM

    1. Synchronization schedule should be inherited (by default it's the schedule of the parent mailbox except for special cases like INBOX and All Mail).
    2. That should happen when using “File > Synchronize > ...” or “Mailbox > Synchronize” on an account.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages