#2657 new
Suchit

Tags do not work when attempting multiple tagging actions simultaneously

Reported by Suchit | September 24th, 2020 @ 01:55 PM

I use a gmail imap account in MailMate (Version 1.13.2 (5673)) on my Macbook. When I attempt to perform multiple simultaneous tagging actions, the tags, or a subset of them, are lost.
For example,
- if I select multiple messages and add some tag to those messages, and remove a tag from all those messages using the tagging interface (T shortcut), the remove operation does not perform. - if I attempt to remove and add tags from a single message, it works as expected - if I define a keyboard shortcut to remove and tag and add one tag, the result is inconsistent. For example, if I want to make mutually exclusive tags of 'save' and 'to_delete', I want to use a shortcut that tags a message as 'to_delete' and at the same time remove any pre-existing 'save' tag. The outcome of such an action is inconsistent, i.e. sometimes both actions perform, but most of the times, the 'to_delete' tag is added but the 'save' tag is not removed.

I think this is happening because MailMate attempts to sync with the Gmail server before the user enters all the tagging actions, and only a subset of the tags get synced with the Gmail server as a result, the ones that the user entered before MailMate attempted the sync.

A potential fix could be to initiate sync only after all tagging requests are complete. For example, in case of the mutually exclusive tagging example above, I am listing two tagging actions in my shortcut, but MailMate probably starts syncing with Gmail immediately after the first action. Instead, if MailMate did not sync by default after the first tagging actions and instead an explicit sync action was available, I would add the sync step after all the tagging steps in my shortcut command.

Comments and changes to this ticket

  • benny

    benny September 30th, 2020 @ 01:54 PM

    First of all, make sure the issue also exists with the current test release [r5722]](http://updates.mailmate-app.com/archives/MailMate_r5722.tbz). There is a known issue with the tagging interface, but I forgot exactly what happened.

    If it still fails, then try making the changes while the account is offline. The problem might not be that synchronzation has started (especially not when using the T shortcut).

    Finally, Gmail is weird. If you have a non-Gmail account then it would be nice to know if it has the same issue.

    (You can use the Activity Viewer in the Window menu if you want to know exactly what MailMate tells the server to do. Make your test case as simple as possible, e.g., a simple IMAP mailbox with 1 or 2 messages.)

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages