#225 ✓fixreleased
Vincent Noel

copy image in Safari, paste as attachment

Reported by Vincent Noel | January 24th, 2012 @ 01:48 PM

If I copy an image in a webpage from Safari (using the right-click menu, for instance), and paste it in a message I'm composing, I would expect the image to appear as an attachment in the message (as happens when I copy an image from the Finder). Instead, what gets pasted is the name of the image.

Comments and changes to this ticket

  • benny

    benny January 26th, 2012 @ 03:36 PM

    • State changed from “new” to “fixcommitted”

    Thanks, I can reproduce this problem. Drag'n'drop works and so does using the Copy menu item in the finder on an image.

    I've made a quick fix for this. And I also fixed an issue with “Copy Link” where a name for the link was pasted instead of the URL. And I've changed the behavior for clicking links in the composer. They can now only be single clicked if holding down ⌘. (Or opened using the “Open Link” menu item.)

  • benny

    benny March 21st, 2012 @ 04:40 PM

    • State changed from “fixcommitted” to “fixreleased”

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages