#1502 ✓cantreproduce
Bill Cole

MM fails to recognize successful mailbox deletion

Reported by Bill Cole | July 28th, 2016 @ 02:18 AM

When deleting an empty mailbox, I got an alert from MM that deletion failed, with the text of the message from Dovecot indicating that the mailbox did not exist. The activity log shows what happened:

01:59:05 C: C7 SELECT "Lists.ldap-UM" (CONDSTORE)
01:59:05 S: * OK [CLOSED] Previous mailbox closed.
01:59:05 S: * FLAGS (\Answered \Flagged \Deleted \Seen \Draft $NotJunk)
01:59:05 S: * OK [PERMANENTFLAGS (\Answered \Flagged \Deleted \Seen \Draft $NotJunk *)] Flags permitted.
01:59:05 S: * 0 EXISTS
01:59:05 S: * 0 RECENT
01:59:05 S: * OK [UIDVALIDITY 1228513827] UIDs valid
01:59:05 S: * OK [UIDNEXT 1004] Predicted next UID
01:59:05 S: * OK [HIGHESTMODSEQ 6] Highest
01:59:05 S: C7 OK [READ-WRITE] Select completed (0.000 + 0.000 secs).
01:59:05 Attempting fast synchronization.
01:59:05 C: C8 UID FETCH 1004:* (UID)
01:59:05 S: C8 OK Fetch completed (0.001 + 0.000 secs).
01:59:05 Completed action (1002). Observed read/write timeouts: 9/9

01:59:05 Handling reply
01:59:05 Running action
01:59:05 Sending request (31226)
01:59:05 Handling request
01:59:05 Ready to run action (retry count: 0)
01:59:05 Deleting mailbox
01:59:05 C: N9 LIST Lists ""
01:59:05 S: * LIST (\Noselect) "." ""
01:59:05 S: N9 OK List completed (0.000 + 0.000 secs).
01:59:05 C: N10 DELETE "Lists.ldap-UM"
01:59:06 S: N10 OK Delete completed (0.000 + 0.000 secs).
01:59:06 C: N11 UNSUBSCRIBE "Lists.ldap-UM"
01:59:06 S: * BYE Selected mailbox was deleted, have to disconnect.
01:59:06 Error: TCP socket was unexpectedly closed.
01:59:06 S:
01:59:06 Error code: 2
01:59:06 Failed action (1013). Reset observed read/write timeouts: 9/9

01:59:06 Handling reply
01:59:06 Running action
01:59:06 Sending request (48178)
01:59:06 Handling request
01:59:06 Clearing connection to toaster.scconsult.com
01:59:07 Ready to run action (retry count: 1)
01:59:07 Clearing connection to toaster.scconsult.com
01:59:07 Trying to connect to toaster.scconsult.com on port 993
01:59:07 Successful connection on socket 87.
01:59:07 Initiating secure connection...
01:59:07 Setup of secure connection complete (TLSv1).
01:59:07 Cipher: DHE-RSA-AES256-SHA SSLv3 Kx=DH Au=RSA Enc=AES(256) Mac=SHA1
01:59:07 S: * OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE AUTH=PLAIN AUTH=LOGIN] Dovecot ready.
01:59:07 Retrieving password (keychain or user request)
01:59:07 C: N0 AUTHENTICATE PLAIN ••••••••••
01:59:07 S: N0 OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE SORT SORT=DISPLAY THREAD=REFERENCES THREAD=REFS THREAD=ORDEREDSUBJECT MULTIAPPEND URL-PARTIAL CATENATE UNSELECT CHILDREN NAMESPACE UIDPLUS LIST-EXTENDED I18NLEVEL=1 CONDSTORE QRESYNC ESEARCH ESORT SEARCHRES WITHIN CONTEXT=SEARCH LIST-STATUS BINARY MOVE SEARCH=FUZZY SPECIAL-USE] Logged in
01:59:07 C: N1 CAPABILITY
01:59:07 S: * CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE SORT SORT=DISPLAY THREAD=REFERENCES THREAD=REFS THREAD=ORDEREDSUBJECT MULTIAPPEND URL-PARTIAL CATENATE UNSELECT CHILDREN NAMESPACE UIDPLUS LIST-EXTENDED I18NLEVEL=1 CONDSTORE QRESYNC ESEARCH ESORT SEARCHRES WITHIN CONTEXT=SEARCH LIST-STATUS BINARY MOVE SEARCH=FUZZY SPECIAL-USE
01:59:07 S: N1 OK Capability completed.
01:59:07 C: N2 ID ("name" "MailMate" "version" "r5234" "vendor" "Freron Software" "contact" "mm-imap-id@freron.com")
01:59:07 S: * ID ("name" "Dovecot")
01:59:07 S: N2 OK ID completed (0.000 + 0.000 secs).
01:59:07 Deleting mailbox
01:59:07 C: N3 LIST Lists ""
01:59:07 S: * LIST (\Noselect) "." ""
01:59:07 S: N3 OK List completed (0.000 + 0.000 secs).
01:59:07 C: N4 DELETE "Lists.ldap-UM"
01:59:07 S: N4 NO [NONEXISTENT] Mailbox doesn't exist: Lists.ldap-UM (0.000 + 0.000 secs).
01:59:07 Error: Server response: “N4 NO [NONEXISTENT] Mailbox doesn't exist: Lists.ldap-UM (0.000 + 0.000 secs).”. Command attempted: “N4 DELETE "Lists.ldap-UM"”.
01:59:07 Error code: 1019
01:59:07 Failed action (1013). Reset observed read/write timeouts: 9/9

It seems that MM is failing to recognize its success in deleting the mailbox, not understanding why it has been kicked offline, and coming back to try deleting the mailbox again even though it no longer exists.

Comments and changes to this ticket

  • benny

    benny August 1st, 2016 @ 10:18 AM

    • State changed from “new” to “cantreproduce”

    Which revision of MailMate is this? I believe I improved handling of NONEXISTENT recently, but I'm not sure it was this exact issue. Could you try the 2.0 beta (described on the mailing list)? You can still go back to 1.9.x. That's if this is a reproducible issue.

  • Bill Cole

    Bill Cole August 1st, 2016 @ 12:12 PM

    r5234, and it happens on 2 different machines.

    I'll give the latest revision of 1.9.4 a test and the 2.0 beta if that doesn't resolve it.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages