#1027 ✓resolved
Jake

settag/removetag Syntax

Reported by Jake | January 31st, 2015 @ 12:54 PM

I'm attempting to use a custom key bindings file to change the behaviour of flagged messages and running into an issue where sometimes settag/removetag doesn't seem to be working. Relevant entries:

    "F" = {
            "0" = ( "removeTag:", "\\Flagged", 
                    "removeTag:", "$MailFlagBit0", 
                    "removeTag:", "$MailFlagBit1", 
                    "removeTag:", "$MailFlagBit2", 
                    "removeTag:", "DoToday", 
                    "removeTag:", "ThisWeek", 
                    "removeTag:", "NextWeek", 
                    "removeTag:", "ThisMonth", 
                    "removeTag:", "Travel", 
                    "removeTag:", "Ideas", 
                    "removeTag:", "Delegated"
                    "setTag:", "CLEARCLEARCLEAR" );

            "1" = ( "setTag:", "\\Flagged", 
                    "removeTag:", "$MailFlagBit0", 
                    "removeTag:", "$MailFlagBit1", 
                    "removeTag:", "$MailFlagBit2", 
                    "removeTag:", "ThisWeek", 
                    "removeTag:", "NextWeek", 
                    "removeTag:", "ThisMonth",
                    "removeTag:", "Travel", 
                    "removeTag:", "Ideas", 
                    "removeTag:", "Delegated",
                    "setTag:", "DoToday", 
                    "removeTag:", "CLEARCLEARCLEAR" );

When I use F0, "\Flagged" is cleared as well as the $MailFlagBit(s), but none of my custom tags are removed.

When I use F1, "\Flagged" is set as expected, but "DoToday" is not. Further, previously set custom tags (ThisWeek, NextWeek, etc) are not cleared.

Am I missing something obvious? I'm using 2.0 features on build 5035.

Comments and changes to this ticket

  • benny

    benny January 31st, 2015 @ 07:59 PM

    I cannot see any obvious problems. Note that the value used for the tags must be the IMAP keyword of each tag and not the display name, but it doesn't look like that is the problem.

    Can I convince you to attempt to reduce the problem to something a bit more simple before I try to reproduce it?

    I assume you don't have issues setting/removing any of these tags when not using these key bindings?

    Oh, a comma is missing after "Delegated", but I don't think that explains your problems.

  • benny

    benny February 17th, 2015 @ 10:51 PM

    • State changed from “new” to “resolved”

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Mac OS X email client.

Shared Ticket Bins

People watching this ticket

Pages